retrofit v2.7.0 Release Notes

Release Date: 2019-12-09 // over 1 year ago
  • ๐Ÿš€ This release changes the minimum requirements to Java 8+ or Android 5+. ๐Ÿ‘€ See this blog post for more information on the change.

    • New: Upgrade to OkHttp 3.14.4. Please see its changelog for 3.x.
    • Fix: Allow service interfaces to extend other interfaces.
    • Fix: Ensure a non-null body is returned by Response.error.